<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" /><script type="text/javascript">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</script>
	<link rel="pingback" href="https://washington.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="chowhound, recipes, cbs" />
<meta name="keywords" content="chowhound, recipes, cbs" />
<meta property="fb:pages" content="129313830492372" />
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<title>15-Minute Dinners For When You Need To East Fast &#8211; CBS DC</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="google855be8f85869d202.html" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CBS DC &raquo; Feed" href="https://washington.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS DC &raquo; Comments Feed" href="https://washington.cbslocal.com/comments/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://washington.cbslocal.com/_static/??-eJytj0sOwjAMRC9EsKoCKgvEWfIxJapjR/mI6xNSNqygEivbY7/RGB5RWeGCXKDcMWAGa7IisZrAs6XqXlLOcBMpmPat3cFPEAaDbmVjQhLtvsOR6uw5QxBXqW3026DV7XA/UEGznjF1mw9FtZBLkbjhpdWjBsPakyLPy/9TIbWJS//3Gi7DcRrG0+E8Tk91oJ9h' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://washington.cbslocal.com/_static/??-eJyNy1EOQDAMgOELmSJGPIizTDVIulrSirg9u4B4/fP9cCWHhxiJgW0USQFndXxgYFC7mUpULeCL7YJ8LjmpQgorOaOYONiPNy/EbxTTrKc41r5vq6HxnX8AIdc5IA==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://washington.cbslocal.com/_static/??-eJydUtFuwyAM/KFR1Kld14dp3+KAlbIYjMBplL8fNO2qLdM29nZg3/nOoKeoDAfBIFpO6DFr02VFbIB0pLF3IWvPdqRSuTQoDwF6TNrkcjNH3G0KetA/CblgaLT1qnAmZ1EJ+kggmBvJEZL8gfPVeT5xEsM3lfuxYTz6Du3Cv0BFLosyIEDcN8YoKZwhVOf78j7VbZHWXSEOZUqXIM06y0y48S60py8b71E+tl/xSsSP6kZ7Q4lghhVdOKrIuaDFS7OP9f/xkIYqvfQbJk7/eN3fdPmMaUpO1pa/SV3pV1zbX/3Ldn983G2Pz0+Hd+G9Mqc=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://washington.cbslocal.com/_static/??-eJy1kNEOwiAMRX9IRqZZog/Gb2HQYWcpcxTN/l5cfNAnNxOfCuXe00v1fVA2sgCLljMESNq2SVG0hjSypexKq096iDR1SFQF5KpPG73U2C9yDJQ9ctIhukzlxbjZXIq6bd8JH+hrhnF6la8CFdCPRuCnPLNABcPGw/hEfzRUmXeROKxaTJfZCkZO/wgEVG4saVUi486Q8LZsQ0XvKbaG1o0YBS3B6u/e0XmQGfE6FsQpHOvmUO93dbNv+gd2Fgp/'></script>
<link rel='https://api.w.org/' href='https://washington.cbslocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://washington.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://washington.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://cbsloc.al/2Biyave' />
<link rel="alternate" type="application/json+oembed" href="https://washington.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwashington.cbslocal.com%2F2020%2F06%2F18%2F15-minute-fast-dinner-recipes%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://washington.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwashington.cbslocal.com%2F2020%2F06%2F18%2F15-minute-fast-dinner-recipes%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="15-Minute Dinners For When You Need To East Fast" /><meta property="og:image" content="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/chowhound111111111.jpg?w=987" /><meta property="og:image:secure_url" content="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/chowhound111111111.jpg?w=987" /><meta property="og:image:width" content="987" /><meta property="og:image:height" content="548" /><meta property="og:description" content="Does the idea of a 15 minute dinner sound completely impossible? Or like the best it could conceivably be is a microwaved afterthought? Well, these truly easy dinner recipe ideas prove both doubts to be unfounded." /><meta property="og:type" content="article" /><meta property="og:url" content="https://washington.cbslocal.com/2020/06/18/15-minute-fast-dinner-recipes/" /><meta property="article:published_time" content="2020-06-18T11:29:50+00:00" /><meta property="article:suggested-social-copy" content="Does the idea of a 15 minute dinner sound completely impossible? Or like the best it could conceivably be is a microwaved afterthought? Well, these truly easy dinner recipe ideas prove both doubts to be unfounded." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Food &amp; Drink" /><meta property="article:publisher" content="https://www.facebook.com/cbsdc" /><meta property="article:author" content="https://www.facebook.com/cbsdc" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/chowhound111111111.jpg?w=987"><meta name="twitter:title" content="15-Minute Dinners For When You Need To East Fast"/><meta name="twitter:description" content="Does the idea of a 15 minute dinner sound completely impossible? Or like the best it could conceivably be is a microwaved afterthought? Well, these truly easy dinner recipe ideas prove both doubts to be unfounded."/><meta name="twitter:site" content="/cbsdc"/>
<link rel="canonical" href="https://washington.cbslocal.com/2020/06/18/15-minute-fast-dinner-recipes/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://washington.cbslocal.com/2020/06/18/15-minute-fast-dinner-recipes/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/washington.cbslocal.com","url":"https:\/\/washington.cbslocal.com","name":"CBS DC","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/washington.cbslocal.com\/wp-content\/uploads\/sites\/15909891\/2018\/07\/2_cbs_dc.png?w=144"}},"url":"https:\/\/washington.cbslocal.com\/2020\/06\/18\/15-minute-fast-dinner-recipes\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/washington.cbslocal.com\/2020\/06\/18\/15-minute-fast-dinner-recipes\/"},"headline":"15-Minute Dinners For When You Need To East Fast","description":"Does the idea of a 15 minute dinner sound completely impossible? Or like the best it could conceivably be is a microwaved afterthought? Well, these truly easy dinner recipe ideas prove both doubts to be unfounded.","image":"https:\/\/washington.cbslocal.com\/wp-content\/uploads\/sites\/15909891\/2020\/06\/chowhound111111111.jpg?w=150&#038;h=150&#038;crop=1","keywords":["Food &amp; Drink","Chowhound","Recipes","15-Minute Dinners For When You Need To East Fast"],"datePublished":"2020-06-18T11:29:50+00:00","dateModified":"2020-06-18T11:29:50+00:00"}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.WASHINGTON","default",["15minutedinnersforwhenyouneedtoeastfast","post","article","foodanddrink","chowhound","recipes","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("1");</script>
		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 10px;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="Does the idea of a 15 minute dinner sound completely impossible? Or like the best it could conceivably be is a microwaved afterthought? Well, these truly easy dinner recipe ideas prove both doubts to be unfounded." />
<script>//<![CDATA[
//]]></script>

</head>

<body class="post-template-default single single-post postid-548871 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://washington.cbslocal.com" id="header-logo"><img src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2018/07/2_cbs_dc.png?w=144" alt="CBS DC" /></a>
	
	<nav id="navigation-main" data-item-count="6"><ul class="top"><li class="menu-top-item item-0 section-item"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="http://washington.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://washington.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="http://washington.cbslocal.com/category/autos/" title="Autos" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Autos</strong></div></a><a href="http://washington.cbslocal.com/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://washington.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="http://washington.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Healines</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://washington.cbslocal.com/2020/06/12/economic-recovery-reopening-safety-unemployment-vaccine-immunity/" title="&#039;Expectations Of Safety&#039; Are Greatest Obstacles In Economy&#039;s Road To Recovery, Prof Says" class="cbs-thumbnail-link item-1591975667" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/mall-tennessee.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;Expectations Of Safety&#039; Are Greatest Obstacles In Economy&#039;s Road To Recovery, Prof Says</strong><em class="description">With so much uncertainty in the world, economic recovery will be a long, slow process.</em></div></a><a href="https://washington.cbslocal.com/2020/06/05/may-unemployment-numbers-surprise-drop-temporary-layoffs-pete-kyle/" title="Unemployment Unexpectedly Drops, But Full Recovery Not Imminent" class="cbs-thumbnail-link item-1591376660" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/unemployment-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Unemployment Unexpectedly Drops, But Full Recovery Not Imminent</strong><em class="description">The unemployment rate took a surprising drop, but while hope exists the road to recovery remains uncertain.</em></div></a><a href="https://washington.cbslocal.com/2020/06/03/restaurants-sit-down-delivery-takeout-coronavirus/" title="What Restaurants Will Survive Coronavirus?" class="cbs-thumbnail-link item-1591213529" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/cipriani-restaurant-nyc-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">What Restaurants Will Survive Coronavirus?</strong><em class="description">Restaurants that rely on in-house dining will continue to struggle, while delivery and takeout spots will likely thrive.</em></div></a><a href="https://washington.cbslocal.com/2020/06/02/rent-mortgage-missed-payments-coronavirus-economy-local-services/" title="What Happens When You Don&#039;t Pay Rent?" class="cbs-thumbnail-link item-1591112560" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/rent-freeze-nyc-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">What Happens When You Don&#039;t Pay Rent?</strong><em class="description">Missed rent and mortgage payments can have a domino effect that hurts communities and depresses the economy.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="http://washington.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://washington.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="http://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a><a href="http://www.sportsline.com/" title="Odds" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Headlines</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://washington.cbslocal.com/2020/06/17/rbc-heritage-preview-harbour-town-golf-links-rory-mcilroy-dottie-pepper/" title="Harbour Town &#039;Places Premium On Short Game,&#039; Says Dottie Pepper On RBC Heritage" class="cbs-thumbnail-link item-1592420489" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/ct-pan-rbc-heritage-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Harbour Town &#039;Places Premium On Short Game,&#039; Says Dottie Pepper On RBC Heritage</strong><em class="description">Harbour Town Golf Links welcomes a major-caliber field for the RBC Heritage, as the PGA Tour enters the second week of the resumed season.</em></div></a><a href="https://washington.cbslocal.com/2020/06/16/nwsl-challenge-cup-opening-match-airs-on-cbs-saturday-june-27/" title="NWSL Challenge Cup Opening Match Airs On CBS Saturday, June 27" class="cbs-thumbnail-link item-1592322362" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/GettyImages-1183835631.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">NWSL Challenge Cup Opening Match Airs On CBS Saturday, June 27</strong><em class="description">The league&#039;s last two champions will square off in the opening match of the 2020 NWSL Challenge Cup live on CBS Saturday June 27.</em></div></a><a href="https://washington.cbslocal.com/2020/06/16/harbour-town-golf-links-profile-pete-dye-rbc-heritage/" title="Harbour Town Golf Links Profile: Shot-Making Excellence Required At RBC Heritage" class="cbs-thumbnail-link item-1592317850" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/ct-pan-harbour-town-18th-hole-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Harbour Town Golf Links Profile: Shot-Making Excellence Required At RBC Heritage</strong><em class="description">Harbour Town Golf Links, home of this week&#039;s RBC Heritage, offers a strategic minimalist design within the serene setting of Hilton Head.</em></div></a><a href="https://washington.cbslocal.com/2020/06/12/wwe-backlash-2020-picks-edge-randy-orton-asuka-nia-jax/" title="WWE Backlash Picks: Will Edge, Randy Orton Have The Greatest Wrestling Match Ever?" class="cbs-thumbnail-link item-1591984309" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/edge-randy-orton-raw-wwe.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">WWE Backlash Picks: Will Edge, Randy Orton Have The Greatest Wrestling Match Ever?</strong><em class="description">Aside from the highly touted Edge-Randy Orton match, multiple titles will be on the line at WWE&#039;s Backlash, including the Raw Women’s Championship.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link"><a href="http://washington.cbslocal.com/live/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://washington.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Headlines</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://washington.cbslocal.com/2020/05/22/quarantine-cooking-nonstick-cookware-guide/" title="Quarantine Cooking: Your Essential Nonstick Cookware Guide" class="cbs-thumbnail-link item-1590161120" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/05/nonstickpans.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Cooking: Your Essential Nonstick Cookware Guide</strong><em class="description">Step up your quarantine cooking with this guide to nonstick cookware.</em></div></a><a href="https://washington.cbslocal.com/2020/05/22/how-to-6-easy-steps-to-make-homemade-soft-pretzels/" title="How To: 6 Easy Steps To Make Homemade Soft Pretzels" class="cbs-thumbnail-link item-1590161082" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/05/homemadepretzel.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How To: 6 Easy Steps To Make Homemade Soft Pretzels</strong><em class="description">Learn how to make your own homemade soft pretzels with these six easy steps!</em></div></a><a href="https://washington.cbslocal.com/2020/05/15/recipes-vodka-in-vodka-sauce-why/" title="5 Vodka Sauce Recipes To Try This Week" class="cbs-thumbnail-link item-1589569648" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/05/chowhound111.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">5 Vodka Sauce Recipes To Try This Week</strong><em class="description">And would you miss it if it wasn&#039;t there?</em></div></a><a href="https://washington.cbslocal.com/2020/05/15/best-make-ahead-freezer-meals/" title="Try These Make-Ahead Freezer Meals Perfect For Weeknights" class="cbs-thumbnail-link item-1589569416" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/05/freezerfood.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Try These Make-Ahead Freezer Meals Perfect For Weeknights</strong><em class="description">Set yourself up for easy weeknight dinners no matter what!</em></div></a><a href="https://washington.cbslocal.com/2020/05/13/the-most-searched-recipe-in-every-state-during-quarantine-coronavirus/" title="Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine" class="cbs-thumbnail-link item-1589398031" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/05/QuarantineRecipesFeat.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine</strong><em class="description">Find the most popular eats for your home state and across the country during the coronavirus quarantine.</em></div></a><a href="https://washington.cbslocal.com/2020/05/13/how-to-make-homemade-bagels-quarantine/" title="Quarantine Recipes: How To Make Homemade Bagels" class="cbs-thumbnail-link item-1589397541" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/05/bagelfeat.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Recipes: How To Make Homemade Bagels</strong><em class="description">See how to make your own homemade bagels while stuck inside during quarantine.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="http://washington.cbslocal.com/category/health/" title="Health" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Headlines</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://washington.cbslocal.com/2020/05/12/researchers-developing-device-that-could-detect-covid-19-using-your-smartphone/" title="Researchers Developing Device That Could Detect COVID-19 Using Your Smartphone" class="cbs-thumbnail-link item-1589316806" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/05/sensor-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Researchers Developing Device That Could Detect COVID-19 Using Your Smartphone</strong><em class="description">What started as a device to help detect a Zika virus could become be programmed to identify COVID-19 instead, say researchers in Utah.</em></div></a><a href="https://washington.cbslocal.com/2019/05/03/baltimore-dc-among-nations-grossest-cities/" title="Baltimore, DC Among America&#039;s Filthiest Cities" class="cbs-thumbnail-link item-1556897230" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2019/05/470461810.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Baltimore, DC Among America&#039;s Filthiest Cities</strong><em class="description">Baltimore is among the nation&#039;s filthiest cities.</em></div></a><a href="https://washington.cbslocal.com/2019/04/24/baltimore-ranked-one-of-most-ozone-polluted-cities/" title="Baltimore-Washington Area Gets Failing Grade For Air Quality" class="cbs-thumbnail-link item-1556134363" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2019/05/airpollution.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Baltimore-Washington Area Gets Failing Grade For Air Quality</strong><em class="description">Baltimore and Anne Arundel counties received a failing grade in the annual State of the Air report. </em></div></a><a href="https://washington.cbslocal.com/2019/04/16/sara-hinesley-born-without-hands-resilient/" title="&#039;I Just Try My Hardest&#039; | 10-Year-Old Maryland Girl Born Without Hands Wins Handwriting Contest" class="cbs-thumbnail-link item-1555447383" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2019/04/sara3.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;I Just Try My Hardest&#039; | 10-Year-Old Maryland Girl Born Without Hands Wins Handwriting Contest</strong><em class="description">A Frederick girl, born without hands, is overcoming obstacles and excelling at school.</em></div></a><a href="https://washington.cbslocal.com/2019/04/16/randolph-smith-charged-hiv-spread-frederick/" title="Frederick Man Charged After Allegedly Transferring HIV To Women He Met Online" class="cbs-thumbnail-link item-1555445765" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2019/04/randolph-smith-.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Frederick Man Charged After Allegedly Transferring HIV To Women He Met Online</strong><em class="description">A Frederick man was charged after he allegedly had sex with multiple woman while he knew he was HIV positive.</em></div></a><a href="https://washington.cbslocal.com/2019/04/11/nationwide-shortage-of-school-nurses-maryland/" title="Nationwide Shortage Of School Nurses Also Putting Maryland Students Lives At Risk" class="cbs-thumbnail-link item-1554987735" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2019/04/doctor-07062012.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Nationwide Shortage Of School Nurses Also Putting Maryland Students Lives At Risk</strong><em class="description">Only three out of five schools across the country have full-time school nurses often forcing school administrators, with no medical training, to step in.</em></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	
	
	<div id="info-search"><form action="https://washington.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">15-Minute Dinners For When You Need To East Fast</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">June 18, 2020 at 11:29 am</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://washington.cbslocal.com/tag/chowhound/">Chowhound</a>, <a href="https://washington.cbslocal.com/tag/recipes/">Recipes</a></div></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-youtube  close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper youtube"><div id="youtube_player_1"></div>
<script language="javascript">
var tag = document.createElement("script");
tag.src = "https://www.youtube.com/iframe_api";
var firstScriptTag = document.getElementsByTagName("script")[0];
firstScriptTag.parentNode.insertBefore(tag, firstScriptTag);
var youtube_player_1;
function onYouTubePlayerAPIReady() {
youtube_player_1 = new YT.Player("youtube_player_1", { height: 250, width: 358, videoId: "f0dyduD7ajw", playerVars: {autoplay: 1, controls: 2, modestbranding: 1, showinfo: 0, wmode: "transparent"}, });
}
</script>
</div></section>
<div class="main-story-wrapper"><section class="col gu1">
<div class="fr_stickypane">
<div id="body_top_sharelinks" class="clear clearfix">
<div class="fr_social_bubbles">Does the idea of a 15 minute dinner sound completely impossible? Or like the best it could conceivably be is a microwaved afterthought? Well, these truly easy dinner recipe ideas prove both doubts to be unfounded.</div>
</div>
</div>
</section>
<section class="col gu7">
<div id="blog_bd" class="clearfix">
<div id="wp_content" class="widecolumn bt_body ">
<div id="post-266882" class="post-266882 post type-post status-publish format-standard hentry category-food-news category-recipe-round-ups" data-articleurl="https://www.chowhound.com/food-news/266882/15-minute-dinner-ideas/">
<div class="entry ">
<h2>Some Technicalities &amp; Caveats</h2>
<p>The amount of time it takes to do any given task varies on who is doing it and under what conditions&mdash;but in general, this collection of easy recipes adheres to some ground rules and guidelines:</p>
<ul>
<li>They don&rsquo;t require a ton of chopping (at least not by hand), because not everyone&rsquo;s knife skills are so well honed.</li>
<li>They don&rsquo;t involve making several separate components, because you literally don&rsquo;t have time for that.</li>
<li>They don&rsquo;t depend on special equipment, and yes, that includes the&nbsp;<a href="https://www.chowhound.com/food-news/250563/what-to-do-with-your-new-instant-pot/" target="_blank" rel="noopener noreferrer">Instant Pot</a>.</li>
<li>They take full advantage of store-bought shortcuts, like pre-made pizza dough and&nbsp;<a href="https://www.chowhound.com/food-news/256709/best-slow-cooker-sauces-to-buy/" target="_blank" rel="noopener noreferrer">store-bought sauces</a>. (There are, however, several options that&nbsp;<em>don&rsquo;t</em>&nbsp;call for anything beyond standard&nbsp;<a href="https://www.chowhound.com/food-news/263471/kitchen-pantry-guide-pantry-food-staples-how-to-store-and-what-to-cook-with-them/" target="_blank" rel="noopener noreferrer">pantry staples</a>, in case you aren&rsquo;t planning on a store run before you eat.)</li>
<li>They often utilize leftovers you may have laying around (but again, not all of them require these convenient components, so you&rsquo;ll find something you can pull off below, no matter what).</li>
</ul>
<div id="attachment_264776" class="wp-caption alignnone">
<div id="attachment_264776" style="width: 680px" class="wp-caption alignnone"><a class="pinterest-pin share_pinterest" title="Pin it on Pinterest!" href="http://pinterest.com/pin/create/button/?url=https://www.chowhound.com/food-news/266882/15-minute-dinner-ideas/&amp;description=15%20Minute%20Dinner%20Ideas%20-%20ChowhoundBack%20ButtonSearch%20IconFilter%20IconArrow&amp;media=https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2018/09/easy-one-pot-recipes-chowhound-670x446.jpg" target="_blank" rel="nofollow" data-social-location="article-body"><img aria-describedby="caption-attachment-264776" class="lazy-loaded wp-image-264776 size-chow-full-width" src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2018/09/easy-one-pot-recipes-chowhound-670x446.jpg" alt="easy one pot recipe ideas" width="670" height="446" data-src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2018/09/easy-one-pot-recipes-chowhound-670x446.jpg"></a><p id="caption-attachment-264776" class="wp-caption-text">Photo Courtesy of Chowhound</p></div>
</div>
<p><strong>Related Reading:&nbsp;<a href="https://www.chowhound.com/food-news/207426/easy-one-pot-meals-and-recipes-that-minimize-kitchen-messes/" target="_blank" rel="noopener noreferrer">Easy One-Pot Meals to Minimize Kitchen Mess</a></strong></p>
<h2>Active Time vs Total Time</h2>
<p>Far too many 15 minute recipes actually take&nbsp;<em>way</em>&nbsp;longer once you factor in passive time&mdash;like 30 minutes to boil&nbsp;<a href="https://www.chowhound.com/food-news/155024/easy-pasta-recipes-to-make-with-pantry-staples-puttanesca-tomato-butter-sauce-and-carbonara-without-bacon/" target="_blank" rel="noopener noreferrer">pasta</a>&nbsp;water (not so bad, really, especially if you can prep the rest while it&rsquo;s coming to temp), or four hours to&nbsp;<a href="https://www.chowhound.com/food-news/166510/healthy-marinated-grilled-chicken-recipes-for-summer/" target="_blank" rel="noopener noreferrer">marinate chicken</a>&nbsp;(yeah, right). For the most part, I&rsquo;ve tried to avoid those hidden time sucks, or provide hacks for speeding them up where possible, but sometimes you just can&rsquo;t get around preheating the oven.</p>
<h2>Easy 15 Minute Dinner Recipes</h2>
<p>Now, on to the actual cooking! Plus, plenty of suggestions for adapting almost all of these ideas depending on your particular circumstances:</p>
<h3><a href="https://www.chowhound.com/recipes/bean-and-cheese-breakfast-taco-31124" target="_blank" rel="noopener noreferrer">Bean and Cheese Breakfast Tacos</a></h3>
<div id="attachment_263921" class="wp-caption alignnone">
<div id="attachment_263921" style="width: 680px" class="wp-caption alignnone"><a class="pinterest-pin share_pinterest" title="Pin it on Pinterest!" href="http://pinterest.com/pin/create/button/?url=https://www.chowhound.com/food-news/266882/15-minute-dinner-ideas/&amp;description=15%20Minute%20Dinner%20Ideas%20-%20ChowhoundBack%20ButtonSearch%20IconFilter%20IconArrow&amp;media=https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2014/06/fried-egg-bean-taco-recipe-chowhound-670x447.jpg" target="_blank" rel="nofollow" data-social-location="article-body"><img aria-describedby="caption-attachment-263921" class="lazy-loaded wp-image-263921 size-chow-full-width" src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2014/06/fried-egg-bean-taco-recipe-chowhound-670x447.jpg" alt="fried egg and bean breakfast taco recipe" width="670" height="447" data-src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2014/06/fried-egg-bean-taco-recipe-chowhound-670x447.jpg"></a><p id="caption-attachment-263921" class="wp-caption-text">Photo Courtesy of Chowhound</p></div>
</div>
<p>Open up a can of beans, crack an egg, and combine them with shredded cheese in a breakfast-for-dinner taco that takes well to tweaks of all sorts. Add jarred salsa or leftover cooked veggies if you have them; swap Greek yogurt for sour cream if that&rsquo;s what you&rsquo;ve got; pile on&nbsp;<a href="https://www.chowhound.com/food-news/263719/how-to-quick-pickle-anything/" target="_blank" rel="noopener noreferrer">pickled onions</a>&nbsp;if some are hanging out in the fridge; ditto leftover ground beef, shredded chicken, or chorizo. Get our&nbsp;<a href="https://www.chowhound.com/recipes/bean-and-cheese-breakfast-taco-31124" target="_blank" rel="noopener noreferrer">Egg Taco recipe</a>.</p>
<h3>Streamlined Stir Fry</h3>
<div id="attachment_263189" class="wp-caption alignnone">
<div id="attachment_263189" style="width: 680px" class="wp-caption alignnone"><a class="pinterest-pin share_pinterest" title="Pin it on Pinterest!" href="http://pinterest.com/pin/create/button/?url=https://www.chowhound.com/food-news/266882/15-minute-dinner-ideas/&amp;description=15%20Minute%20Dinner%20Ideas%20-%20ChowhoundBack%20ButtonSearch%20IconFilter%20IconArrow&amp;media=https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2019/04/snow-pea-shrimp-stir-fry-recipe-chowhound-670x447.jpg" target="_blank" rel="nofollow" data-social-location="article-body"><img aria-describedby="caption-attachment-263189" class="lazy-loaded wp-image-263189 size-chow-full-width" src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2019/04/snow-pea-shrimp-stir-fry-recipe-chowhound-670x447.jpg" alt="snow pea shrimp stir fry recipe" width="670" height="447" data-src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2019/04/snow-pea-shrimp-stir-fry-recipe-chowhound-670x447.jpg"></a><p id="caption-attachment-263189" class="wp-caption-text">Photo Courtesy of Chowhound</p></div>
</div>
<p><a href="https://www.chowhound.com/food-news/182319/how-to-improve-your-stir-fry/" target="_blank" rel="noopener noreferrer">Stir fries</a>&nbsp;are fast&nbsp;<em>cooking</em>&nbsp;for sure, but it can take a staggering amount of time to actually prepare all the ingredients, especially if a lot of veggies are involved. One way to get around that is to cave and buy pre-chopped vegetables at the store (fresh or frozen)&mdash;or just stick to something like snow peas, which need very minimal prep.</p>
<p>As for protein, ground chicken or pork will cook quickly and won&rsquo;t need to be sliced or diced. Shrimp is also a good choice if it&rsquo;s already peeled and deveined. Or buy pre-sliced steak from the store.</p>
<p>If you have a rice cooker, you can let that make the side for you&mdash;but to stick to the strict(ish) 15-minute rule, other options include nuking frozen cauliflower rice or adding quick-cooking noodles to the pan (like&nbsp;<a href="https://ohsweetbasil.com/quick-easy-15-minute-chicken-stir-fry-recipe/" target="_blank" rel="nofollow">yakisoba noodles</a>,&nbsp;<a href="https://www.chowhound.com/food-news/187696/rice-noodles-vermicelli-what-is-the-difference/" target="_blank" rel="noopener noreferrer">rice vermicelli</a>, or even&nbsp;<a href="https://www.chowhound.com/food-news/262385/recipes-for-ramen-noodles-besides-soup/" target="_blank" rel="noopener noreferrer">ramen noodles</a>). For noodles you need to cook or soften in hot water, if you have an electric kettle, that&rsquo;s usually much faster than boiling water on the stove.</p>
<h3><a href="https://www.chowhound.com/recipes/chicken-guacamole-and-bean-nachos-28065" target="_blank" rel="noopener noreferrer">Leftover Chicken Nachos</a>&nbsp;or&nbsp;<a href="https://www.chowhound.com/recipes/chili-cheese-nachos-28063" target="_blank" rel="noopener noreferrer">Chili Cheese Nachos</a></h3>
<div id="attachment_240212" class="wp-caption alignnone">
<div id="attachment_240212" style="width: 680px" class="wp-caption alignnone"><a class="pinterest-pin share_pinterest" title="Pin it on Pinterest!" href="http://pinterest.com/pin/create/button/?url=https://www.chowhound.com/food-news/266882/15-minute-dinner-ideas/&amp;description=15%20Minute%20Dinner%20Ideas%20-%20ChowhoundBack%20ButtonSearch%20IconFilter%20IconArrow&amp;media=https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2020/09/leftover-chili-nacho-recipe-chowhound-670x446.jpg" target="_blank" rel="nofollow" data-social-location="article-body"><img aria-describedby="caption-attachment-240212" class="lazy-loaded wp-image-240212 size-chow-full-width" src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2020/09/leftover-chili-nacho-recipe-chowhound-670x446.jpg" alt="leftover chili nacho recipe" width="670" height="446" data-src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2020/09/leftover-chili-nacho-recipe-chowhound-670x446.jpg"></a><p id="caption-attachment-240212" class="wp-caption-text">Photo Courtesy of Chowhound</p></div>
</div>
<p><a title="Nachos" href="https://www.chowhound.com/recipes/pulled-pork-nachos-28064" target="_blank" rel="noopener noreferrer">Nachos</a>&nbsp;are, in my opinion, a totally acceptable dinner, especially on a Friday. You can pile on whatever leftover meat you have, or even use&nbsp;<a href="https://www.chowhound.com/food-news/217105/how-to-make-canned-chili-taste-homemade/" target="_blank" rel="noopener noreferrer">canned chili</a>&nbsp;(doctored just a bit if the taste is underwhelming) to make things more substantial. If you don&rsquo;t have any of that, a well-drained can of beans by itself will do nicely. If you want more veggies&mdash;which really makes it feel like a meal&mdash;add fresh or canned corn kernels, jarred roasted peppers roughly torn to pieces, sliced onions or&nbsp;<a href="https://www.chowhound.com/food-news/265860/how-to-regrow-scallions/" target="_blank" rel="noopener noreferrer">scallions</a>, and chopped tomatoes.</p>
<p>If you&rsquo;re out of tortilla chips, stack a few flour or corn tortillas in a pile, use a pizza cutter to slice them into chip-size wedges, and bake before you build your nachos. This will take a little longer, but it won&rsquo;t feel like too much work. You can even&nbsp;<a href="https://www.simplyrecipes.com/recipes/how_to_make_homemade_tortilla_chips/" target="_blank" rel="nofollow">microwave the homemade chips</a> (and then the nachos) if you don&rsquo;t want to turn on the oven.</p>
<p><strong>Related Reading:&nbsp;<a href="https://www.chowhound.com/food-news/173605/sheet-pan-dinner-ideas-for-easy-cooking-and-cleaning-up/" target="_blank" rel="noopener noreferrer">11 Easy Sheet Pan Dinner Recipes</a></strong></p>
<h3>Scrambled Eggs with Extras</h3>
<div id="attachment_229795" class="wp-caption alignnone">
<div id="attachment_229795" style="width: 680px" class="wp-caption alignnone"><a class="pinterest-pin share_pinterest" title="Pin it on Pinterest!" href="http://pinterest.com/pin/create/button/?url=https://www.chowhound.com/food-news/266882/15-minute-dinner-ideas/&amp;description=15%20Minute%20Dinner%20Ideas%20-%20ChowhoundBack%20ButtonSearch%20IconFilter%20IconArrow&amp;media=https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2015/09/joes-special-ground-beef-spinach-scramble-recipe-chowhound-670x447.jpg" target="_blank" rel="nofollow" data-social-location="article-body"><img aria-describedby="caption-attachment-229795" class="lazy-loaded wp-image-229795 size-chow-full-width" src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2015/09/joes-special-ground-beef-spinach-scramble-recipe-chowhound-670x447.jpg" alt="Joe's Special ground beef spinach scramble recipe" width="670" height="447" data-src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2015/09/joes-special-ground-beef-spinach-scramble-recipe-chowhound-670x447.jpg"></a><p id="caption-attachment-229795" class="wp-caption-text">Photo Credit: Chowhound</p></div>
</div>
<p>A quick dish of scrambled eggs is a beautifully blank canvas for you to transform into your own edible masterpiece. Use time-saving frozen spinach and ground beef for a&nbsp;<a href="https://www.chowhound.com/recipes/joes-special-31241" target="_blank" rel="noopener noreferrer">Joe&rsquo;s Special</a>, as seen above. Or add a chunk of&nbsp;<a href="https://www.chowhound.com/food-news/194268/ways-to-use-up-leftover-cream-cheese/" target="_blank" rel="noopener noreferrer">cream cheese</a>&nbsp;to enrich your scramble and&nbsp;<a href="https://www.chowhound.com/recipes/cream-cheese-and-chive-scramble-with-prosciutto-10963" target="_blank" rel="noopener noreferrer">wrap the finished eggs in a silky, salty blanket of prosciutto</a>:</p>
<div id="attachment_260424" class="wp-caption alignnone">
<div id="attachment_260424" style="width: 680px" class="wp-caption alignnone"><a class="pinterest-pin share_pinterest" title="Pin it on Pinterest!" href="http://pinterest.com/pin/create/button/?url=https://www.chowhound.com/food-news/266882/15-minute-dinner-ideas/&amp;description=15%20Minute%20Dinner%20Ideas%20-%20ChowhoundBack%20ButtonSearch%20IconFilter%20IconArrow&amp;media=https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2019/04/prosciutto-wrapped-scrambled-egg-recipe-chowhound-670x447.jpg" target="_blank" rel="nofollow" data-social-location="article-body"><img aria-describedby="caption-attachment-260424" class="lazy-loaded wp-image-260424 size-chow-full-width" src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2019/04/prosciutto-wrapped-scrambled-egg-recipe-chowhound-670x447.jpg" alt="prosciutto wrapped scrambled eggs with leftover cream cheese" width="670" height="447" data-src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2019/04/prosciutto-wrapped-scrambled-egg-recipe-chowhound-670x447.jpg"></a><p id="caption-attachment-260424" class="wp-caption-text">Photo Credit: Chowhound</p></div>
</div>
<p>Toss a simple salad to serve on the side and it&rsquo;s like you teleported to a fancy French bistro. The effect is only slightly diminished if you use a slice of deli ham.</p>
<h3><a href="https://www.chowhound.com/recipes/easy-shrimp-pho-31811" target="_blank" rel="noopener noreferrer">Quick Chicken Pho</a></h3>
<div id="attachment_200093" class="wp-caption alignnone"></div>
<p>Calling this&nbsp;<a href="https://www.chowhound.com/food-news/221273/how-to-make-bun-bo-hue/" target="_blank" rel="noopener noreferrer">pho</a>&nbsp;may feel wrong, but eating it feels&nbsp;<em>so</em>&nbsp;right. It does depend on pre-cooked poultry, whether that&rsquo;s from a&nbsp;<a href="https://www.chowhound.com/food-news/181500/easy-dinner-ideas-for-rotisserie-chicken/" target="_blank" rel="noopener noreferrer">rotisserie chicken</a>&nbsp;you picked up or leftovers from a&nbsp;<a href="https://www.chowhound.com/food-news/54493/how-to-make-easy-roasted-chicken/" target="_blank" rel="noopener noreferrer">homemade roasted chicken</a>. Pre-cleaned shrimp work here too; you can cook them right in the hot broth. You can soften the vermicelli noodles that way too (just be sure to only use the amount you&rsquo;ll eat that day and add them right at the end since they only need a few minutes to cook). You can also swap in&nbsp;<a href="https://www.chowhound.com/food-news/262385/recipes-for-ramen-noodles-besides-soup/" target="_blank" rel="noopener noreferrer">ramen noodles</a>&nbsp;if that&rsquo;s what you have in the pantry. Definitely best with a big pile of fresh herbs and sliced scallions.</p>
<h3>Fried Rice with Leftover Protein and Veg</h3>
<div id="attachment_261465" class="wp-caption alignnone">
<div id="attachment_261465" style="width: 680px" class="wp-caption alignnone"><a class="pinterest-pin share_pinterest" title="Pin it on Pinterest!" href="http://pinterest.com/pin/create/button/?url=https://www.chowhound.com/food-news/266882/15-minute-dinner-ideas/&amp;description=15%20Minute%20Dinner%20Ideas%20-%20ChowhoundBack%20ButtonSearch%20IconFilter%20IconArrow&amp;media=https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2020/04/hanakimchifriedrice-670x893.jpg" target="_blank" rel="nofollow" data-social-location="article-body"><img aria-describedby="caption-attachment-261465" class="lazy-loaded wp-image-261465 size-chow-full-width" src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2020/04/hanakimchifriedrice-670x893.jpg" alt="kimchi fried rice recipe with bacon" width="670" height="893" data-src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2020/04/hanakimchifriedrice-670x893.jpg"></a><p id="caption-attachment-261465" class="wp-caption-text">Photo Credit: Hana Asbrink</p></div>
</div>
<p>If you love&nbsp;<a href="https://www.chowhound.com/food-news/185812/fried-rice-recipes/" target="_blank" rel="noopener noreferrer">fried rice</a>&nbsp;(who doesn&rsquo;t?), make it a habit to cook extra grains any time you have rice as a side dish and you&rsquo;ll be assured of a quick, delicious dinner a day or two down the road. Literally any kind of rice will work; even leftover&nbsp;<a href="https://www.chowhound.com/food-news/55206/whole-grains-guide-quinoa-barley-buckwheat-millet-and-more/" target="_blank" rel="noopener noreferrer">whole grains</a>&nbsp;can be prepared in the same manner. And even if you don&rsquo;t have much in the way of already-cooked protein or veggies on hand to mix in, a simple sauce and a fried egg are all you really need.&nbsp;<a href="https://www.chowhound.com/food-news/261431/best-kimchi-fried-rice-bokkeumbap-bacon-recipe-ultimate-comfort-food/" target="_blank" rel="noopener noreferrer">Kimchi and bacon</a>&nbsp;don&rsquo;t hurt. Ditto&nbsp;<a href="https://www.chowhound.com/food-news/266186/how-to-make-easy-chili-oil-or-chili-crisp/" target="_blank" rel="noopener noreferrer">chili oil</a>. Frozen peas and carrots are easy nutrition-boosters to toss in too.</p>
<h3><a href="https://www.chowhound.com/recipes/breakfast-pita-pizza-30076" target="_blank" rel="noopener noreferrer">Pita Pizza</a></h3>
<div id="attachment_236242" class="wp-caption alignnone">
<div id="attachment_236242" style="width: 710px" class="wp-caption alignnone"><a class="pinterest-pin share_pinterest" title="Pin it on Pinterest!" href="http://pinterest.com/pin/create/button/?url=https://www.chowhound.com/food-news/266882/15-minute-dinner-ideas/&amp;description=15%20Minute%20Dinner%20Ideas%20-%20ChowhoundBack%20ButtonSearch%20IconFilter%20IconArrow&amp;media=https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2019/08/gorgonzola-blue-cheese-tomato-pizza-recipe-chowhound.jpg" target="_blank" rel="nofollow" data-social-location="article-body"><img aria-describedby="caption-attachment-236242" class="lazy-loaded wp-image-236242 size-full" src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2019/08/gorgonzola-blue-cheese-tomato-pizza-recipe-chowhound.jpg" alt="Gorgonzola Blue Cheese Tomato Pizza recipe with heriloom tomatoes" width="700" height="620" data-src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2019/08/gorgonzola-blue-cheese-tomato-pizza-recipe-chowhound.jpg"></a><p id="caption-attachment-236242" class="wp-caption-text">Photo Credit: Chowhound</p></div>
</div>
<p>Even if you use&nbsp;<a href="https://www.chowhound.com/food-news/145822/easy-pizza-dough-recipe-hacks/" target="_blank" rel="noopener noreferrer">store-bought pizza dough</a>, you&rsquo;re looking at a 30 minute wait time to let it relax at room temp before you can even shape your crust. Using pita, naan, or other (pre-made) flatbread is a quicker route to pizza for dinner. Top it with whatever you like&mdash;jarred sauce, shredded mozz, pepperoni, and olives; fig jam and blue cheese; store-bought pesto and thinly sliced tomatoes or zucchini&mdash;and pop it in the oven til golden. This is but one excellent reason to stock some&nbsp;<a href="https://www.chowhound.com/food-news/264339/gourmet-pantry-food-to-stock-besides-beans-and-rice/" target="_blank" rel="noopener noreferrer">elevated pantry staples</a>&nbsp;at all times.</p>
<h3><a href="https://www.chowhound.com/recipes/ham-and-camembert-baguette-sandwich-29675" target="_blank" rel="noopener noreferrer">Ham and Camembert Baguette</a></h3>
<div id="attachment_236168" class="wp-caption alignnone">
<div id="attachment_236168" style="width: 680px" class="wp-caption alignnone"><a class="pinterest-pin share_pinterest" title="Pin it on Pinterest!" href="http://pinterest.com/pin/create/button/?url=https://www.chowhound.com/food-news/266882/15-minute-dinner-ideas/&amp;description=15%20Minute%20Dinner%20Ideas%20-%20ChowhoundBack%20ButtonSearch%20IconFilter%20IconArrow&amp;media=https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2019/08/ham-cheese-baguette-sandwich-recipe-chowhound-670x446.jpg" target="_blank" rel="nofollow" data-social-location="article-body"><img aria-describedby="caption-attachment-236168" class="lazy-loaded wp-image-236168 size-chow-full-width" src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2019/08/ham-cheese-baguette-sandwich-recipe-chowhound-670x446.jpg" alt="ham and cheese baguette sandwich for picnic with fig jam or peach jam" width="670" height="446" data-src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2019/08/ham-cheese-baguette-sandwich-recipe-chowhound-670x446.jpg"></a><p id="caption-attachment-236168" class="wp-caption-text">Photo Credit: Chowhound</p></div>
</div>
<p>There&rsquo;s nothing wrong with a sandwich for dinner, but you may want something a little less pedestrian than what passes muster at lunch. This one strikes a perfect balance between simple and sophisticated&mdash;but if you don&rsquo;t have any fancy French cheese, use swiss and spread the bread generously with salted butter for a similar effect. (That&rsquo;s my go-to beach picnic sandwich but I&rsquo;ll happily eat it standing at the kitchen counter any Tuesday night.) A salad on the side is a welcome bit of green.</p>
<p>Another easy way to amp up sandwiches and make them dinner-worthy is to whip up a quick spread, like our&nbsp;<a href="https://www.chowhound.com/recipes/sun-dried-tomatoricotta-basil-spread-27616" target="_blank" rel="noopener noreferrer">Sundried Tomato Ricotta Spread</a>, or a cheater&rsquo;s&nbsp;<a href="https://www.chowhound.com/food-news/169480/mayonnaise-aioli-and-hollandaise-whats-the-difference/" target="_blank" rel="noopener noreferrer">aioli</a>&nbsp;(i.e., minced garlic mixed into mayo, preferably with&nbsp;<a href="https://www.chowhound.com/food-news/167373/how-to-use-fresh-herbs-before-they-go-bad/" target="_blank" rel="noopener noreferrer">fresh herbs</a>&nbsp;along for the ride).</p>
<p>It&rsquo;s also well worth keeping some crusty rolls in your freezer for when the fancy sandwich urge strikes; thaw them on reduced power in the microwave (check often since times and temp settings vary) and give them a quick toast if you like.</p>
<h3><a href="https://www.chowhound.com/recipes/shrimp-greens-salad-yogurt-avocado-dressing-31358" target="_blank" rel="noopener noreferrer">Shrimp and Greens Salad with Yogurt-Avocado Dressing</a></h3>
<div id="attachment_267005" class="wp-caption alignnone">
<div id="attachment_267005" style="width: 680px" class="wp-caption alignnone"><a class="pinterest-pin share_pinterest" title="Pin it on Pinterest!" href="http://pinterest.com/pin/create/button/?url=https://www.chowhound.com/food-news/266882/15-minute-dinner-ideas/&amp;description=15%20Minute%20Dinner%20Ideas%20-%20ChowhoundBack%20ButtonSearch%20IconFilter%20IconArrow&amp;media=https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2021/05/easy-shrimp-salad-recipe-chowhound-670x433.jpg" target="_blank" rel="nofollow" data-social-location="article-body"><img aria-describedby="caption-attachment-267005" class="lazy-loaded wp-image-267005 size-chow-full-width" src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2021/05/easy-shrimp-salad-recipe-chowhound-670x433.jpg" alt="easy shrimp green salad recipe" width="670" height="433" data-src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2021/05/easy-shrimp-salad-recipe-chowhound-670x433.jpg"></a><p id="caption-attachment-267005" class="wp-caption-text">Photo Credit: Chowhound</p></div>
</div>
<p>Salads are well suited to quick dinners too, but I get that the prospect can seem&hellip;uninspiring. Our&nbsp;<a href="https://www.chowhound.com/food-news/57481/best-salad-recipes-tips-tricks/" target="_blank" rel="noopener noreferrer">guide to troubleshooting salad</a>&nbsp;will help you get a handle on how to make them exciting again&mdash;namely, by thinking about the interplay of texture and flavor at every level&mdash;and then you can riff based on what you have in your fridge and cupboards. One summery option is this simple mix of greens, seafood, and a dairy-free, creamy&nbsp;<a href="https://www.chowhound.com/food-news/265890/best-salad-dressing-recipes/" target="_blank" rel="noopener noreferrer">dressing</a>&nbsp;that you blend while the shrimp briefly marinate.</p>
<p>As we&rsquo;ve established, shrimp cook really quickly&mdash;and buying them peeled and deveined will save you significant time. But if they&rsquo;re still frozen when you get a craving, quick-thaw them under running cold water for about five minutes, then pat them dry.</p>
<h3><a href="https://www.chowhound.com/recipes/summer-peach-caprese-salad-32078" target="_blank" rel="noopener noreferrer">Peach Caprese Salad</a></h3>
<div id="attachment_267006" class="wp-caption alignnone">
<div id="attachment_267006" style="width: 680px" class="wp-caption alignnone"><a class="pinterest-pin share_pinterest" title="Pin it on Pinterest!" href="http://pinterest.com/pin/create/button/?url=https://www.chowhound.com/food-news/266882/15-minute-dinner-ideas/&amp;description=15%20Minute%20Dinner%20Ideas%20-%20ChowhoundBack%20ButtonSearch%20IconFilter%20IconArrow&amp;media=https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2021/05/joanna-gaines-peach-caprese-salad-recipe-chowhound-670x876.jpg" target="_blank" rel="nofollow" data-social-location="article-body"><img aria-describedby="caption-attachment-267006" class="lazy-loaded wp-image-267006 size-chow-full-width" src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2021/05/joanna-gaines-peach-caprese-salad-recipe-chowhound-670x876.jpg" alt="Joanna Gaines peach caprese salad recipe" width="670" height="876" data-src="https://chowhound1.cbsistatic.com/thumbnail/800/0/chowhound1.cbsistatic.com/blog-media/2021/05/joanna-gaines-peach-caprese-salad-recipe-chowhound-670x876.jpg"></a><p id="caption-attachment-267006" class="wp-caption-text">Photo Credit: Amy Neunsinger</p></div>
</div>
<p>This is a slice and serve meal at its best. Peak-season peaches paired with creamy mozzarella or burrata, torn basil for a spicy, herbal bite, and an easy vinaigrette are summer perfection on the plate. Add some bread for swiping up the fruity juices as they mingle with the dressing and you&rsquo;ll be very happy. And plenty full. Get Joanna Gaines&rsquo;&nbsp;<a href="https://www.chowhound.com/recipes/summer-peach-caprese-salad-32078" target="_blank" rel="noopener noreferrer">Peach Caprese Salad recipe</a>.</p>
</div>
<div class="author_bio">
<div class="author_img lazy-loaded"><em>Article provided by ViacomCBS site <a href="https://www.chowhound.com/" target="_blank" rel="noopener noreferrer">Chowhound.com</a>. All featured products are curated independently by Chowhound editors. When you buy something through their retail links, they may receive a commission.</em></div>
<div></div>
<div class="author_bio_w"><em>Jen is an editor at Chowhound. Raised on&nbsp;sc<a href="https://www.chowhound.com/food-news/194141/loving-scrapple-a-cherished-memory-of-mid-atlantic-mystery-meat-2/" target="_blank" rel="noopener noreferrer">r</a>apple&nbsp;and&nbsp;blue crabs, she hails from Baltimore, Maryland, but has lived in Portland (Oregon) for so long it feels like home. She enjoys the rain, reads, writes, eats, and cooks voraciously, and stops to pet every stray cat she sees. Continually working on building her Gourmet magazine collection, she will never get over its cancellation.&nbsp;<a href="https://www.chowhound.com/team/jen-wheeler" target="_blank" rel="noopener noreferrer">Read more of her work</a>.</em></div>
</div>
</div>
</div>
</div>
</section>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/2Biyave"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/2Biyave"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/2Biyave"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/cbsdc" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/cbsdc" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://washington.cbslocal.com/2015/12/14/study-african-american-names-16-less-likely-to-be-approved-for-airbnb-rentals/" title="Study: &#039;African-American Names&#039; 16% Less Likely to Be Approved for Airbnb Rentals" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/washington.cbslocal.com/wp-content/uploads/sites/15909891/2015/12/gettyimages-485917269.jpg?resize=55%2C55&#038;ssl=1" alt="Study: &#039;African-American Names&#039; 16% Less Likely to Be Approved for Airbnb Rentals" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://washington.cbslocal.com/2015/12/14/study-african-american-names-16-less-likely-to-be-approved-for-airbnb-rentals/" title="Study: &#039;African-American Names&#039; 16% Less Likely to Be Approved for Airbnb Rentals" class="bump-view" data-bump-view="tp">Study: &#039;African-American Names&#039; 16% Less Likely to Be Approved for Airbnb Rentals</a>
							</div>
													</li>
										<li>
						<a href="https://washington.cbslocal.com/2020/05/29/haircut-night-in-america-jerry-oconnell/" title="Jerry O&#039;Connell On &#039;Haircut Night In America&#039;: &#039;It Just Made Us Laugh&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/05/HAIRCUTNIGHTSTILLS_005.jpg?resize=55%2C55&#038;ssl=1" alt="Jerry O&#039;Connell On &#039;Haircut Night In America&#039;: &#039;It Just Made Us Laugh&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://washington.cbslocal.com/2020/05/29/haircut-night-in-america-jerry-oconnell/" title="Jerry O&#039;Connell On &#039;Haircut Night In America&#039;: &#039;It Just Made Us Laugh&#039;" class="bump-view" data-bump-view="tp">Jerry O&#039;Connell On &#039;Haircut Night In America&#039;: &#039;It Just Made Us Laugh&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://washington.cbslocal.com/2013/07/16/two-years-later-what-really-caused-the-death-of-amy-winehouse-2/" title="Two Years Later: What Really Caused the Death of Amy Winehouse" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/washington.cbslocal.com/wp-content/uploads/sites/15909891/2013/07/103636817.jpg?resize=55%2C55&#038;ssl=1" alt="Two Years Later: What Really Caused the Death of Amy Winehouse" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://washington.cbslocal.com/2013/07/16/two-years-later-what-really-caused-the-death-of-amy-winehouse-2/" title="Two Years Later: What Really Caused the Death of Amy Winehouse" class="bump-view" data-bump-view="tp">Two Years Later: What Really Caused the Death of Amy Winehouse</a>
							</div>
													</li>
										<li>
						<a href="https://washington.cbslocal.com/2013/10/15/peta-change-redskins-logo-from-indian-head-to-potato/" title="PETA: Change Redskins Logo From Indian Head To Potato" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/washington.cbslocal.com/wp-content/uploads/sites/15909891/2013/10/redskins2.jpg?resize=55%2C55&#038;ssl=1" alt="PETA: Change Redskins Logo From Indian Head To Potato" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://washington.cbslocal.com/2013/10/15/peta-change-redskins-logo-from-indian-head-to-potato/" title="PETA: Change Redskins Logo From Indian Head To Potato" class="bump-view" data-bump-view="tp">PETA: Change Redskins Logo From Indian Head To Potato</a>
							</div>
													</li>
										<li>
						<a href="https://washington.cbslocal.com/2020/06/05/may-unemployment-numbers-surprise-drop-temporary-layoffs-pete-kyle/" title="Unemployment Unexpectedly Drops, But Full Recovery Not Imminent" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/unemployment-1.jpg?resize=55%2C55&#038;ssl=1" alt="Unemployment Unexpectedly Drops, But Full Recovery Not Imminent" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://washington.cbslocal.com/2020/06/05/may-unemployment-numbers-surprise-drop-temporary-layoffs-pete-kyle/" title="Unemployment Unexpectedly Drops, But Full Recovery Not Imminent" class="bump-view" data-bump-view="tp">Unemployment Unexpectedly Drops, But Full Recovery Not Imminent</a>
							</div>
													</li>
										<li>
						<a href="https://washington.cbslocal.com/2020/06/02/rent-mortgage-missed-payments-coronavirus-economy-local-services/" title="What Happens When You Don&#039;t Pay Rent?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/rent-freeze-nyc-1.jpg?resize=55%2C55&#038;ssl=1" alt="What Happens When You Don&#039;t Pay Rent?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://washington.cbslocal.com/2020/06/02/rent-mortgage-missed-payments-coronavirus-economy-local-services/" title="What Happens When You Don&#039;t Pay Rent?" class="bump-view" data-bump-view="tp">What Happens When You Don&#039;t Pay Rent?</a>
							</div>
													</li>
										<li>
						<a href="https://washington.cbslocal.com/2020/05/13/the-most-searched-recipe-in-every-state-during-quarantine-coronavirus/" title="Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/05/QuarantineRecipesFeat.jpg?resize=55%2C55&#038;ssl=1" alt="Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://washington.cbslocal.com/2020/05/13/the-most-searched-recipe-in-every-state-during-quarantine-coronavirus/" title="Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine" class="bump-view" data-bump-view="tp">Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine</a>
							</div>
													</li>
										<li>
						<a href="https://washington.cbslocal.com/2020/05/15/recipes-vodka-in-vodka-sauce-why/" title="5 Vodka Sauce Recipes To Try This Week" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/05/chowhound111.jpg?resize=55%2C55&#038;ssl=1" alt="5 Vodka Sauce Recipes To Try This Week" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://washington.cbslocal.com/2020/05/15/recipes-vodka-in-vodka-sauce-why/" title="5 Vodka Sauce Recipes To Try This Week" class="bump-view" data-bump-view="tp">5 Vodka Sauce Recipes To Try This Week</a>
							</div>
													</li>
										<li>
						<a href="https://washington.cbslocal.com/2014/01/14/obama-on-executive-actions-ive-got-a-pen-and-ive-got-a-phone/" title="Obama On Executive Actions: &#039;I&#039;ve Got A Pen And I&#039;ve Got A Phone&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/washington.cbslocal.com/wp-content/uploads/sites/15909891/2014/01/462638511.jpg?resize=55%2C55&#038;ssl=1" alt="Obama On Executive Actions: &#039;I&#039;ve Got A Pen And I&#039;ve Got A Phone&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://washington.cbslocal.com/2014/01/14/obama-on-executive-actions-ive-got-a-pen-and-ive-got-a-phone/" title="Obama On Executive Actions: &#039;I&#039;ve Got A Pen And I&#039;ve Got A Phone&#039;" class="bump-view" data-bump-view="tp">Obama On Executive Actions: &#039;I&#039;ve Got A Pen And I&#039;ve Got A Phone&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://washington.cbslocal.com/2020/06/10/its-a-really-inspirational-story-kenneth-sims-jr-destyne-butler-jr-on-showtime-documentary-ringside/" title="&#039;It&#039;s A Really Inspirational Story&#039;: Kenneth Sims Jr. &amp; Destyne Butler Jr. On Showtime Documentary &#039;Ringside&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/washington.cbslocal.com/wp-content/uploads/sites/15909891/2020/06/Ringside_0001_R-e1591802572535.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;It&#039;s A Really Inspirational Story&#039;: Kenneth Sims Jr. &amp; Destyne Butler Jr. On Showtime Documentary &#039;Ringside&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://washington.cbslocal.com/2020/06/10/its-a-really-inspirational-story-kenneth-sims-jr-destyne-butler-jr-on-showtime-documentary-ringside/" title="&#039;It&#039;s A Really Inspirational Story&#039;: Kenneth Sims Jr. &amp; Destyne Butler Jr. On Showtime Documentary &#039;Ringside&#039;" class="bump-view" data-bump-view="tp">&#039;It&#039;s A Really Inspirational Story&#039;: Kenneth Sims Jr. &amp; Destyne Butler Jr. On Showtime Documentary &#039;Ringside&#039;</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://washington.cbslocal.com" class="logo"><img src="https://washington.cbslocal.com/wp-content/uploads/sites/15909891/2017/10/dc.png" alt="CBS DC" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/cbsdc" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/cbsdc" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://washington.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="http://washington.cbslocal.com/category/autos/" title="Autos" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Autos</strong></div></a><a href="http://washington.cbslocal.com/category/only-cbs/" title="Entertainment" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="http://washington.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a><a href="http://washington.cbslocal.com/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://washington.cbslocal.com/category/sports/" title="Latest Sports" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest Sports</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-2" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://washington.cbslocal.com/site-info/" title="Station Info" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Station Info</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://washington.cbslocal.com" class="logo"><img src="https://washington.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS DC" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2020 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=washington.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-151970" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151970"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-151969" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151969"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-546829" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-546829"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-546830" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-546830"><a href="https://ca.privacy.cbs/donotsell">California Do Not Sell My Info</a></li>
<li id="menu-item-434207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-434207"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='all-css-0' href='https://washington.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1563380959g' type='text/css' media='all' />
<script type='text/javascript' src='https://washington.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1591831585g'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202025.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'162246029',post:'548871',tz:'-4',srv:'washington.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246029', '548871' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"103fa8ca15","applicationID":"144794115","transactionName":"ZwdaZBdUX0VTVEBRC15NeVMRXF5YHV5aXAFI","queueTime":0,"applicationTime":254,"atts":"S0BNEl9OTBoQVhYCH00f","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>